方法一

Maven 构建工程默认使用jdk1.5,使用jdk1.8需要以下设置。

<build>
    <plugins>
        <plugin>
            <!--利用Maven编译插件将编译级别提高到1.8,解决lambada表达式错误-->
            <groupId>org.apache.maven.plugins</groupId>
            <!--maven-compiler-plugin是Maven自带的编译插件-->
            <artifactId>maven-compiler-plugin</artifactId>
            <configuration>
                <!--检查源码采用1.8规则,默认为1.5-->
                <source>1.8</source>
                <!--按照1.8规则生产字节码-->
                <target>1.8</target>
            </configuration>
        </plugin>
    </plugins>
</build>

方法二

在maven的settings..xml的<profiles></<profiles>标签中配置maven使用的jdk插件。

<profile>
<!-- 定义的编译器插件 ID,全局唯一 -->
<id>jdk-1.8</id>
<!-- 插件标记,activeByDefault 默认编译器,jdk提供编译器版本 -->
<activation>
    <activeByDefault>true</activeByDefault>
    <jdk>1.8</jdk>
</activation>
<!-- 配置信息 source-源信息,target-字节码信息,compilerVersion-编译过程版本 -->
<properties>
    <maven.compiler.source>1.8</maven.compiler.source>
    <maven.compiler.target>1.8</maven.compiler.target>
    <maven.compiler.compilerVersion>1.8</maven.compiler.compilerVersion>
    <maven.compiler.encoding>utf-8</maven.compiler.encoding>
    <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
</properties>

</profile>
版权属于:it小离

本文链接: https://www.itxiaoli.cn/archives/Maven.html

版权声明:本站文章采用 署名-非商业性使用-相同方式共享 4.0

最后修改:2022 年 03 月 28 日 09 : 56 AM
如果觉得我的文章对你有用,请随意赞赏